aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 11:01:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:51 +0000
commitb34aac7490bbe7eaf73dee67e4585f0163a6ba64 (patch)
treecdf66f492d47e3d2ec70fe4cc686891e9ef65a5a
parent3a02b8a0ee9a1832c7895ced8bdd360f8251b1f4 (diff)
downloadguix-b34aac7490bbe7eaf73dee67e4585f0163a6ba64.tar.gz
guix-b34aac7490bbe7eaf73dee67e4585f0163a6ba64.zip
gnu: restic-rest-server: Fix build.
Fix the build as senn in <https://ci.guix.gnu.org/build/5805924/log/raw>. * gnu/packages/backup.scm (restic-rest-server): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: I84454cddcd39c32f7b87d13d6ea9433c86426c8c
-rw-r--r--gnu/packages/backup.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 0973c5ddca..025398888f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1058,6 +1058,24 @@ precious backup space.
#:unpack-path "github.com/restic/rest-server"
#:phases
#~(modify-phases %standard-phases
+ ;; TODO: Implement it in go-build-system.
+ ;;
+ ;; This happens due to Golang can't determine the valid directory of
+ ;; the module of embed file which is symlinked during setup
+ ;; environment phase, but easy resolved after coping file from the
+ ;; store to the build directory of the current package, see details
+ ;; in Golang source:
+ ;;
+ ;; - URL: <https://github.com/golang/go/blob/>
+ ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
+ ;; - file: src/cmd/go/internal/load/pkg.go#L2059
+ (add-after 'unpack 'fix-embed-files
+ (lambda _
+ (for-each (lambda (file)
+ (let ((file-store-path (readlink file)))
+ (delete-file file)
+ (copy-recursively file-store-path file)))
+ (find-files "src" ".*(editions_defaults.binpb)$"))))
;; Unit tests seems to break with Guix' non-standard TMPDIR.
(add-before 'check 'set-tmpdir
(lambda _