aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 10:58:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:50 +0000
commit3a02b8a0ee9a1832c7895ced8bdd360f8251b1f4 (patch)
tree4f95a6b511d31213df413cec3156eb7ac8dd408f
parent9e237a7d1327fef03041beaa831e4003ba090804 (diff)
downloadguix-3a02b8a0ee9a1832c7895ced8bdd360f8251b1f4.tar.gz
guix-3a02b8a0ee9a1832c7895ced8bdd360f8251b1f4.zip
gnu: miniflux: Fix build.
Fix the build as senn in <https://ci.guix.gnu.org/build/5804243/log/raw>. * gnu/packages/web.scm (miniflux): Fix build. [arguments]: <#:phases>: Add 'fix-embed-files. Change-Id: If266fa82e0e810e340a3c69c80edbacddd6bcefa
-rw-r--r--gnu/packages/web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d21f3f09e6..e5b53e226b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -367,6 +367,24 @@ and its related documentation.")
#$version))
#:phases
#~(modify-phases %standard-phases
+ ;; TODO: Implement it in go-build-system.
+ ;;
+ ;; This happens due to Golang can't determine the valid directory of
+ ;; the module of embed file which is symlinked during setup
+ ;; environment phase, but easy resolved after coping file from the
+ ;; store to the build directory of the current package, see details
+ ;; in Golang source:
+ ;;
+ ;; - URL: <https://github.com/golang/go/blob/>
+ ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
+ ;; - file: src/cmd/go/internal/load/pkg.go#L2059
+ (add-after 'unpack 'fix-embed-files
+ (lambda _
+ (for-each (lambda (file)
+ (let ((file-store-path (readlink file)))
+ (delete-file file)
+ (copy-recursively file-store-path file)))
+ (find-files "src" ".*(editions_defaults.binpb)$"))))
;; XXX: Replace when go-build-system supports nested path.
(replace 'check
(lambda* (#:key import-path tests? #:allow-other-keys)