aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 12:55:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 12:55:05 +0100
commitb09538f682d38f2b586cebc5d3b780a9b5673f1f (patch)
tree18004ee6a49deabbea8f1baf5aeb45c791f182e4
parent404ff118886f782b291bbe1909b2074766dd24c8 (diff)
downloadguix-b09538f682d38f2b586cebc5d3b780a9b5673f1f.tar.gz
guix-b09538f682d38f2b586cebc5d3b780a9b5673f1f.zip
gnu: go-github-com-libp2p-go-cidranger: Disable tests on non 64bit architecture.
As seen in CI <https://ci.guix.gnu.org/build/5483308/log/raw>. * gnu/packages/golang-web.scm (go-github-com-libp2p-go-cidranger): Disable tests on non 64bit architecture. Change-Id: I0954053692c936ead43c3bc058fc34042b0f720e
-rw-r--r--gnu/packages/golang-web.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2ff78eb482..9943891502 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2677,6 +2677,11 @@ router.")
(build-system go-build-system)
(arguments
(list
+ ;; XXX: Check if the most of the tests may be enabled:
+ ;; src/github.com/libp2p/go-cidranger/trie_test.go:557:8: cannot use
+ ;; 4294967295 (untyped int constant) as int value in assignment
+ ;; (overflows).
+ #:tests? (target-64bit?)
#:import-path "github.com/libp2p/go-cidranger"))
(native-inputs
(list go-github-com-stretchr-testify))