aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 12:47:04 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 12:47:04 +0100
commit404ff118886f782b291bbe1909b2074766dd24c8 (patch)
tree0489405214120c7608e2d19e8e0fe672addaa34c
parent4a19fe41c34a519f6320d1e606a79171507d2b05 (diff)
downloadguix-404ff118886f782b291bbe1909b2074766dd24c8.tar.gz
guix-404ff118886f782b291bbe1909b2074766dd24c8.zip
gnu: go-github-com-prometheus-procfs: Disable tests on non x86_64 architecture.
As seen in CI <https://ci.guix.gnu.org/build/5475510/log/raw>. * gnu/packages/prometheus.scm (go-github-com-prometheus-procfs): Disable tests on non x86_64 architecture. Change-Id: I5f8a4431110cd4b64a2310c2d0b8b0b789216e0d
-rw-r--r--gnu/packages/prometheus.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 64c956c0d4..b10bb44a5f 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -409,6 +409,11 @@ from the default AWS credential chain.")
(build-system go-build-system)
(arguments
(list
+ ;; XXX: Check if the most of the tests may be enabled on non x86_64
+ ;; architectures, disable for now: ./proc_stat_test.go:98:49: cannot use
+ ;; math.MinInt64 (untyped int constant -9223372036854775808) as int
+ ;; value in struct literal (overflows).
+ #:tests? (target-x86-64?)
#:import-path "github.com/prometheus/procfs"
#:phases
#~(modify-phases %standard-phases