aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-09-13 14:09:32 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-01 12:09:01 +0100
commitaa7511eeb41b17de3c3eae96fcd0d68d1b374b3b (patch)
tree9e15baae8fb8498ec427cfea2532d0eded6b4a6b
parent3d7b1a2768ae47303c1772014b0707937621bb0a (diff)
downloadguix-aa7511eeb41b17de3c3eae96fcd0d68d1b374b3b.tar.gz
guix-aa7511eeb41b17de3c3eae96fcd0d68d1b374b3b.zip
gnu: Add r-scdesign2.
* gnu/packages/bioinformatics.scm (r-scdesign2): New variable. Change-Id: I25599df1cb8493bc2d9cc1839b5232aee03bf848
-rw-r--r--gnu/packages/bioinformatics.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 070148cb76..e0e8ce81b9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1184,6 +1184,33 @@ high-throughput sequence analysis. The package is primarily useful to
developers of other R packages who wish to make use of HTSlib.")
(license license:lgpl2.0+))))
+(define-public r-scdesign2
+ (let ((commit "554f2c4b1a7ee6cc04969a287df9b3b77d7bb2fe")
+ (revision "1"))
+ (package
+ (name "r-scdesign2")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JSB-UCLA/scDesign2")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09zkz6qdcx54092ab6761ja3pclax9xzana8dk8qvxrdbjshb8p7"))))
+ (properties `((upstream-name . "scDesign2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mass r-pscl))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/JSB-UCLA/scDesign2")
+ (synopsis "Statistical simulator for scRNA-seq with gene correlation")
+ (description
+ "This package offers a flexible statistical simulator for scRNA-seq data.
+It can generate data that captures gene correlation. Additionally, it allows
+for varying the number of cells and sequencing depth.")
+ (license license:expat))))
+
(define-public r-scenic
(let ((commit "cedf8490a634da550cea2c831544e5f7f14467d2")
(revision "1"))