aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:07:17 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:27 +0000
commita8eb940e760304959da7635d7484cd8f0a8dca62 (patch)
treed2cb5a0119a24e072737f1a5ad36d2b570adf643
parent92fba6c72acb2dd5f67e5bb7b0fc6d70e2a4a9ee (diff)
downloadguix-a8eb940e760304959da7635d7484cd8f0a8dca62.tar.gz
guix-a8eb940e760304959da7635d7484cd8f0a8dca62.zip
gnu: python-dirty-equals: Update to 0.8.0.
* gnu/packages/python-xyz.scm (python-dirty-equals): Update to 0.8.0. Adjust package indentation. [arguments]<test-flags>: Silent more tests. [native-inputs]: Remove python-pydantic, to break the cycle. Change-Id: I9499d79a4fc82e692aeed5b95fd69dd63e457635
-rw-r--r--gnu/packages/python-xyz.scm42
1 files changed, 26 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b18d624326..7164a67e90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10487,27 +10487,37 @@ by pycodestyle.")
(define-public python-dirty-equals
(package
(name "python-dirty-equals")
- (version "0.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/samuelcolvin/dirty-equals")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1hw044d6q0ij8hrrbp6wbdb49xbyjd22viansy817hpmd0yf85ja"))))
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/samuelcolvin/dirty-equals")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jp9jbfs90m8jkpcvi798zxxx49a94rzn8gki9fraqhbqxkv76qd"))))
(build-system pyproject-build-system)
(arguments
- ;; This test requires pytest-examples, which in turn requires
- ;; python-ruff, which is difficult to package because it is
- ;; written in Rust (TODO: Enable when Ruff is in Guix!).
- (list #:test-flags #~'("--ignore" "tests/test_docs.py")))
+ (list
+ #:test-flags
+ ;; This test requires pytest-examples, which in turn requires
+ ;; python-ruff, which is difficult to package because it is written in
+ ;; Rust (TODO: Enable when Ruff is in Guix!).
+ #~(list "--ignore=tests/test_docs.py"
+ ;; Optional typing check with Pydantic.
+ "--ignore=tests/test_other.py"
+ ;; TODO: Some timezones are missing in PyTZ, remove constrain
+ ;; when updated.
+ "-k" (string-append "not test_is_datetime_zoneinfo"
+ " and not test_is_now_tz"
+ " and not test_tz"))))
(native-inputs
(list python-hatchling
- python-pydantic
+ ;; python-pydantic ; introduces cycle, optinoal
python-pytest))
- (propagated-inputs (list python-pytz))
+ (propagated-inputs
+ (list python-pytz))
(home-page "https://dirty-equals.helpmanual.io/")
(synopsis "Do dirty (but useful) things with equals")
(description