aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 15:34:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:37 +0000
commita41604d754d8decaf99734478cdc051d84574cb6 (patch)
tree840dfabfa48a04150bbece895558c0b446915de9
parent3feeaf0760ee8fd0fbf72c82e483151b64719952 (diff)
downloadguix-a41604d754d8decaf99734478cdc051d84574cb6.tar.gz
guix-a41604d754d8decaf99734478cdc051d84574cb6.zip
gnu: python-curtsies: Update to 0.4.2.
* gnu/packages/terminals.scm (python-curtsies): Update to 0.4.2. Improve style. [build-system]: Swap to pyproject-build-system. [native-inputs]: Remove python-nose; add python-pytest, python-setuptools, and python-wheel. Change-Id: Ic4ec85ddef8344c72a06e3680ae4a771a2d6dcce
-rw-r--r--gnu/packages/terminals.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index fb318654f6..0f9c5ab352 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1166,30 +1166,28 @@ than a terminal.")
(define-public python-curtsies
(package
(name "python-curtsies")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "curtsies" version))
(sha256
- (base32 "1c122vgfsvksxkd41g2vij6hjsz97ikg59snclq4af2mkhs0zlb2"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "nosetests" "-v"))))))
- (propagated-inputs
- (list python-blessed python-cwcwidth))
+ (base32 "03kn093lr84qg8fmqrn1jb0zak6a1ir9q106lm8jijfpbchk7gkf"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pyte python-nose))
+ (list python-pyte
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-blessed
+ python-cwcwidth))
(home-page "https://github.com/bpython/curtsies")
- (synopsis "Library for curses-like terminal interaction with colored
-strings")
- (description "Curtsies is a Python library for interacting with the
-terminal. It features string-like objects which carry formatting information,
-per-line fullscreen terminal rendering, and keyboard input event reporting.")
+ (synopsis "Library for curses-like terminal interaction with colored strings")
+ (description
+ "Curtsies is a Python library for interacting with the terminal. It
+features string-like objects which carry formatting information, per-line
+fullscreen terminal rendering, and keyboard input event reporting.")
(license license:expat)))
(define-public python-halo