aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 11:41:15 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:36 +0000
commit3feeaf0760ee8fd0fbf72c82e483151b64719952 (patch)
tree697a5903ce9a09ad97b167b6381c64f03a3bb68a
parent35a6ca06605b0252e88f117488e3d8070f870a63 (diff)
downloadguix-3feeaf0760ee8fd0fbf72c82e483151b64719952.tar.gz
guix-3feeaf0760ee8fd0fbf72c82e483151b64719952.zip
gnu: python-pylama: Update to 8.4.1.
* gnu/packages/python-check.scm (python-pylama): Update to 8.4.1. [source]: Swap to git checkout containing tests. [build-system]: Swap to pyrpoect-build-system. [arguments]<phases>: Remove 'disable-failing-tests. <tests>: Switch them off as cycling with python-pylint. [native-inputs]: Remove python-py, python-pytest; add python-setuptools and python-wheel. [propagated-inputs]: Remove labels. [description]: Adjust fill column. Change-Id: If06ada7a80f5b68792adc0587ed7207dec92523f
-rw-r--r--gnu/packages/python-check.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1c92ebf9e8..aa119c90ea 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2334,40 +2334,38 @@ dtypes and shapes of arrays for NumPy, extending @code{numpy.typing}.")
(define-public python-pylama
(package
(name "python-pylama")
- (version "7.7.1")
+ (version "8.4.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pylama" version))
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/klen/pylama")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "13vx7daqz2918y9s8q3v2i3xaq3ah43a9p58srqi6hqskkpm7blv"))))
- (build-system python-build-system)
+ (base32 "1x9cnyfnd574mj8ckd5hbfg2wy128zg0k2cd3zc7vdbnimksvqaq"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- ;; Fails with: "ImportError: cannot import name
- ;; 'commented_out_code_line_numbers' from 'eradicate'".
- (delete-file "pylama/lint/pylama_eradicate.py")
- ;; Requires python-astroid, which fails to build on
- ;; Python 3.9+ (see:
- ;; https://github.com/PyCQA/astroid/issues/881).
- (delete-file "pylama/lint/pylama_pylint.py"))))))
+ (list
+ ;; Cycles with pylint: python-pylama -> python-isort -> python-pylint ->
+ ;; python-pylama
+ #:tests? #f))
(native-inputs
- (list python-py python-pytest python-radon))
+ (list python-setuptools
+ python-wheel))
(propagated-inputs
- `(("python-mccabe" ,python-mccabe)
- ("python-mypy", python-mypy-minimal)
- ("python-pycodestyle" ,python-pycodestyle)
- ("python-pydocstyle" ,python-pydocstyle)
- ("python-pyflakes" ,python-pyflakes)))
+ (list python-mypy-minimal
+ python-mccabe
+ python-pycodestyle
+ python-pydocstyle
+ python-pyflakes))
(home-page "https://github.com/klen/pylama")
(synopsis "Code audit tool for python")
- (description "Pylama is a code audit tool for Python and JavaScript to check
-for style, syntax and other code health metrics. It is essentially a
-convenient wrapper above tools such as Pyflakes, pydocstyle, pycodestyle and
-McCabe, among others.")
+ (description
+ "Pylama is a code audit tool for Python and JavaScript to check for
+style, syntax and other code health metrics. It is essentially a convenient
+wrapper above tools such as Pyflakes, pydocstyle, pycodestyle and McCabe,
+among others.")
(license license:lgpl3+)))
(define-public python-pyannotate