aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:18:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:34 +0200
commita39c6b74400df93f8318583e6b15c9a4bb9d127d (patch)
tree7fd839ea1d7da4dbf5ac8ceeefae5eba474209a2
parent1b44c450c4ef01346335d58efc4a65fad044d312 (diff)
downloadguix-a39c6b74400df93f8318583e6b15c9a4bb9d127d.tar.gz
guix-a39c6b74400df93f8318583e6b15c9a4bb9d127d.zip
gnu: Add texlive-pgfplots.
* gnu/packages/tex.scm (texlive-pgfplots): New variable.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b5432616c1..f0ad3c2a24 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3246,6 +3246,40 @@ booklets.")
PGF/TikZ.")
(license license:lppl1.3+)))
+(define-public texlive-pgfplots
+ (package
+ (name "texlive-pgfplots")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/context/third/pgfplots/"
+ "doc/generic/pgfplots/"
+ "doc/latex/pgfplots/"
+ "doc/plain/pgfplots/"
+ "scripts/pgfplots/"
+ "source/context/third/pgfplots/"
+ "source/latex/pgfplots/"
+ "tex/context/third/pgfplots/"
+ "tex/generic/pgfplots/"
+ "tex/latex/pgfplots/"
+ "tex/plain/pgfplots/")
+ (base32
+ "1c0gah7ia61s435zlyq4ay9snkrs2xcs627wky7c0sp8mgxyybwr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-pgf))
+ (home-page "https://ctan.org/pkg/pgfplots")
+ (synopsis "Create normal/logarithmic plots in two and three dimensions")
+ (description
+ "PGFPlots draws high-quality function plots in normal or logarithmic
+scaling with a user-friendly interface directly in TeX. The user supplies
+axis labels, legend entries and the plot coordinates for one or more plots and
+PGFPlots applies axis scaling, computes any logarithms and axis ticks and
+draws the plots, supporting line plots, scatter plots, piecewise constant
+plots, bar plots, area plots, mesh-- and surface plots and some more.
+PGFPlots is based on PGF/TikZ (PGF); it runs equally for LaTeX/TeX/ConTeXt.")
+ (license license:gpl3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")