aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 13:49:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:27 +0200
commit94c1684024263bb4d6a10a0e0d4ffc2bf07428ca (patch)
tree83087af42b65d41f41de733bfdbe77a7fbad692d
parenta088bebe7c92877d3a2a9ec4927b4c5b0a37c7f4 (diff)
downloadguix-94c1684024263bb4d6a10a0e0d4ffc2bf07428ca.tar.gz
guix-94c1684024263bb4d6a10a0e0d4ffc2bf07428ca.zip
gnu: Add texlive-listngsutf8.
* gnu/packages/tex.scm (texlive-listngsutf8): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ae286e3668..358484726a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7154,6 +7154,33 @@ is needed. Keywords, comments and strings can be typeset using different
styles. Support for @code{hyperref} is provided.")
(license license:lppl1.3+))))
+(define-public texlive-listingsutf8
+ (package
+ (name "texlive-listingsutf8")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/listingsutf8/"
+ "source/latex/listingsutf8/"
+ "tex/latex/listingsutf8/")
+ (base32
+ "152gzkzm7sl3bvggmmfcj1pw74vc40s2kpkbp01fd9i0d0v60wma")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-listings
+ texlive-pdftexcmds
+ texlive-stringenc))
+ (home-page "https://ctan.org/pkg/listingsutf8")
+ (synopsis "Allow UTF-8 in listings input")
+ (description
+ "Package @code{listings} does not support files with multi-byte encodings
+such as UTF-8. In the case of @code{\\lstinputlisting}, a simple workaround
+is possible if a one-byte encoding exists that the file can be converted to.
+The package requires the e-TeX extensions under pdfTeX (in either PDF or DVI
+output mode).")
+ (license license:lppl1.3+)))
+
(define-deprecated-package texlive-latex-listings texlive-listings)
(define-public texlive-jknapltx