aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 13:41:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:27 +0200
commita088bebe7c92877d3a2a9ec4927b4c5b0a37c7f4 (patch)
tree8165632c941e2a602e88391e384cf325ff1b6bfc
parent0918ae8668613ab071330abe298cdb25fc92e43b (diff)
downloadguix-a088bebe7c92877d3a2a9ec4927b4c5b0a37c7f4.tar.gz
guix-a088bebe7c92877d3a2a9ec4927b4c5b0a37c7f4.zip
gnu: Add texlive-incgraph.
* gnu/packages/tex.scm (texlive-incgraph): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index daa391f6c2..ae286e3668 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7315,6 +7315,32 @@ fonts. Note that direct substitutes for the bitmapped EC fonts are available,
via the CM-super, Latin Modern and (in a restricted way) CM-LGC font sets.")
(license license:lppl1.3+)))
+(define-public texlive-incgraph
+ (package
+ (name "texlive-incgraph")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/incgraph/" "tex/latex/incgraph/")
+ (base32
+ "1j5pzhzfbgzd21bq3dh7932pv0052g5l8r0qyx68n3cbsg46lcdk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-bookmark
+ texlive-graphics
+ texlive-pgf))
+ (home-page "https://ctan.org/pkg/incgraph")
+ (synopsis "Sophisticated graphics inclusion in a PDF document")
+ (description
+ "The package provides tools for including graphics at the full size of
+the output medium, or for creating pages whose size is that of the graphic
+they contain. A principal use case is documents that require inclusion
+of (potentially many) scans or photographs. Bookmarking is especially
+supported. The tool box has basic macros and a convenience user interface
+that wraps @code{\\includegraphics}.")
+ (license license:lppl1.3+)))
+
(define-public texlive-inconsolata
(package
(inherit (simple-texlive-package