aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:11:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:03 +0200
commit90ea731a1edf6b0bb8f361bba1e34a7be265eead (patch)
tree6fb6476d2eecda989008f10cac1c4ff81ff013ab
parente6a6c66da981a4e61d4e487aba21652997c5a1a4 (diff)
downloadguix-90ea731a1edf6b0bb8f361bba1e34a7be265eead.tar.gz
guix-90ea731a1edf6b0bb8f361bba1e34a7be265eead.zip
gnu: Add texlive-chemfig.
* gnu/packages/tex.scm (texlive-chemfig): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5452fbc020..521713f12e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16521,6 +16521,27 @@ a picture.")
"The package provides a TikZ library for drawing celtic knots.")
(license license:lppl1.3+)))
+(define-public texlive-chemfig
+ (package
+ (name "texlive-chemfig")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/chemfig/"
+ "tex/generic/chemfig/")
+ (base32
+ "01mai7drwm3y4i3yj4fkwqjyzwlr4dvq467lwdzsbj3dl5fxwgpg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/chemfig")
+ (synopsis "Draw molecules with easy syntax")
+ (description
+ "The package provides the command @code{\\chemfig}, which draws molecules
+using the TikZ package. While the diagrams produced are essentially
+2-dimensional, the package supports many of the conventional notations for
+illustrating the 3-dimensional layout of a molecule.")
+ (license license:lppl1.3c)))
+
(define-public texlive-gates
(package
(name "texlive-gates")