aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-11 21:42:58 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-11 21:45:01 +0100
commit9009cc882da509e6049b287ff942d0d2f73f5ab4 (patch)
tree5b3ebdf199716feeb9ca55fcaa954191251f6c67
parentdc2df5b86942e70c4d9f24533f6609153e9b2889 (diff)
downloadguix-9009cc882da509e6049b287ff942d0d2f73f5ab4.tar.gz
guix-9009cc882da509e6049b287ff942d0d2f73f5ab4.zip
gnu: Add python-term-background.
* gnu/packages/python-xyz.scm (python-term-background): New variable. Change-Id: If3606c0d037afc52842d3adb69af26d35c55f6ce
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa43c8d12f..e91f4156f2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17107,6 +17107,30 @@ a hash value.")
applications from a list of lists of strings. It supports multi-line rows.")
(license license:expat)))
+(define-public python-term-background
+ (package
+ (name "python-term-background")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "term_background" version))
+ (sha256
+ (base32 "0p674silrwc3jncncmdnj1lr6pl2q5qbx0xi3mzjq9sgcs5vmp4n"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (delete-file "setup.py"))))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wrapper python-setuptools-scm python-pkginfo python-pytest)) ; TODO: Remove python-pkginfo
+ (home-page "http://github.com/rocky/shell-term-background")
+ (synopsis "Determine if shell has a light or dark background")
+ (description "This package determines if shell has a light or dark
+background.")
+ (license license:gpl2+)))
+
(define-public python-libarchive-c
(package
(name "python-libarchive-c")