aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-12-02 13:20:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-11 20:17:34 +0000
commitdc2df5b86942e70c4d9f24533f6609153e9b2889 (patch)
tree9d6ba377af7a00b639f947860732187207794fe9
parent98908e0777889aeec2796dbdc4f0809a1898dd3b (diff)
downloadguix-dc2df5b86942e70c4d9f24533f6609153e9b2889.tar.gz
guix-dc2df5b86942e70c4d9f24533f6609153e9b2889.zip
gnu: librewolf: Add %u to Exec option to open URLs.
The context behind this change is that Firefox used to ship a taskcluster/docker/firefox-snap/firefox.desktop file which had an Exec line like this: Exec=@MOZ_APP_NAME@ %u The Guix package would use that file, replacing the token with the path to the binary. Reported in #74648. * gnu/packages/librewolf.scm (librewolf): Add %u to Exec option to open URLs. Change-Id: I8cf5d3886eaf7805209cf12eae0cc875bef6d5dd Reviewed-by: André Batista <nandre@riseup.net> Reviewed-by: Ian Eure <ian@retrospec.tv> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/librewolf.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 5d432cfad8..42d212e9f9 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -605,7 +605,7 @@
(substitute* desktop-file
(("^Exec=@MOZ_APP_NAME@")
(string-append "Exec="
- #$output "/bin/librewolf"))
+ #$output "/bin/librewolf %u"))
(("@MOZ_APP_DISPLAYNAME@")
"LibreWolf")
(("@MOZ_APP_REMOTINGNAME@")