aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commit8f6461b0d635ed95fd5f0415bf6e4fcdd446f3d7 (patch)
treee99877cc2c124b4b35242aacacbfc3469b4926fc
parenta64d60a99aca71615608c9baf73a67fd63753e2c (diff)
downloadguix-8f6461b0d635ed95fd5f0415bf6e4fcdd446f3d7.tar.gz
guix-8f6461b0d635ed95fd5f0415bf6e4fcdd446f3d7.zip
gnu: Add ghc-hclip.
gnu/packages/haskell-xyz.scm (ghc-hclip): New variable. Change-Id: I2d1a2d6e1983eb89a5e61eb05204c2e1c0dc3634
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 30402c8ca7..659171d3d5 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15140,6 +15140,28 @@ footnotes, math, and more.")
Pandoc types.")
(license license:bsd-3)))
+(define-public ghc-hclip
+ (package
+ (name "ghc-hclip")
+ (version "3.0.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "Hclip" version))
+ (sha256
+ (base32 "04ppwm7vfzndrys8x1n8vfb41vzwx59r9xp4dkbiqmrms390pj6q"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "Hclip")))
+ (inputs (list ghc-strict))
+ (home-page "https://github.com/jetho/Hclip")
+ (synopsis
+ "Small cross-platform library for reading and modifying the system clipboard")
+ (description
+ "This package provides a small cross-platform library for reading and
+modifying the system clipboard. It uses @code{xclip} or @code{xsel}
+at runtime.")
+ (license license:bsd-3)))
+
(define-public ghc-hslua-module-path
(package
(name "ghc-hslua-module-path")