aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commita64d60a99aca71615608c9baf73a67fd63753e2c (patch)
treeaaace3c658598e36e91f13e71fbaf3d6d32869a6
parent98a5a1a14d0ef9cb4ed2906fdda42ea3d57a8a13 (diff)
downloadguix-a64d60a99aca71615608c9baf73a67fd63753e2c.tar.gz
guix-a64d60a99aca71615608c9baf73a67fd63753e2c.zip
gnu: Add ghc-vty-6.
* gnu/packages/haskell-xyz.scm (ghc-vty-6): New variable. Change-Id: I2e2dbbe0e99d26f38494fb6bdb51bc6d67e5c02c
-rw-r--r--gnu/packages/haskell-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f6422dba5c..30402c8ca7 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14132,6 +14132,21 @@ given term should not exist.")
to use and to provide good support for common terminal types.")
(license license:bsd-3)))
+(define-public ghc-vty-6
+ (package
+ (inherit ghc-vty)
+ (name "ghc-vty")
+ (version "6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "vty" version))
+ (sha256
+ (base32 "0ywqfdngfv5pnsk5pa99yizpbhdq856sy3z70q2hmpmlc2r4h7vg"))))
+ (properties '((upstream-name . "vty")))
+ (inputs (list ghc-blaze-builder ghc-microlens ghc-microlens-mtl
+ ghc-utf8-string ghc-vector))))
+
(define-public ghc-vty-crossplatform
(package
(name "ghc-vty-crossplatform")