aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 21:44:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:06 +0200
commit8ace45c088497583c5a0a03cff3c09600a3d09b9 (patch)
tree88a5cf8560c969924db6c7d78cdc91424a6c4a0a
parent16b71431dd7d3b1e79db557a09deeb65b684ba74 (diff)
downloadguix-8ace45c088497583c5a0a03cff3c09600a3d09b9.tar.gz
guix-8ace45c088497583c5a0a03cff3c09600a3d09b9.zip
gnu: texlive-fonts-iwona -> texlive-iwona.
* gnu/packages/tex.scm (texlive-iwona): New variable. (texlive-fonts-iwona): Deprecate variable. * gnu/packages/guile-xyz.scm (guile-cv)[native-inputs]: Use new name.
-rw-r--r--gnu/packages/guile-xyz.scm13
-rw-r--r--gnu/packages/tex.scm53
2 files changed, 29 insertions, 37 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 334996df0d..9c0b642b97 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4044,12 +4044,13 @@ feature-set, fully programmable in Guile Scheme.")
(inputs
(list vigra vigra-c guile-2.2))
(native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-booktabs
- texlive-lm
- texlive-siunitx
- texlive-standalone
- texlive-xcolor
- texlive-fonts-iwona)))
+ `(("texlive" ,(texlive-updmap.cfg
+ (list texlive-booktabs
+ texlive-iwona
+ texlive-lm
+ texlive-siunitx
+ texlive-standalone
+ texlive-xcolor)))
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("guile-lib" ,guile2.2-lib)))
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f98945d1f4..884f35c959 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7895,39 +7895,28 @@ TeX metrics (VF and TFM files) and macros for use with LaTeX.")
(define-deprecated-package texlive-fonts-txfonts texlive-txfonts)
-(define-public texlive-fonts-iwona
+(define-public texlive-iwona
(package
- (name "texlive-fonts-iwona")
- (version "0.995b")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://jmn.pl/pliki/Iwona-tex-"
- (string-map (lambda (c)
- (if (char=? c #\.)
- #\_ c))
- version)
- ".zip"))
- (sha256
- (base32
- "13684iqx5granpc5rfvqnmyvdpgpbr1x9y7i7y7bcaq0qxv7ph1x"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/"))
- (unzip (search-input-file %build-inputs "/bin/unzip")))
- (invoke unzip (assoc-ref %build-inputs "source"))
- (mkdir-p target)
- (copy-recursively "iwona" target)
- #t))))
- (native-inputs
- (list unzip))
- (home-page "http://jmn.pl/en/kurier-i-iwona/")
+ (name "texlive-iwona")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/iwona/"
+ "fonts/afm/nowacki/iwona/"
+ "fonts/enc/dvips/iwona/"
+ "fonts/map/dvips/iwona/"
+ "fonts/opentype/nowacki/iwona/"
+ "fonts/tfm/nowacki/iwona/"
+ "fonts/type1/nowacki/iwona/"
+ "tex/latex/iwona/"
+ "tex/plain/iwona/")
+ (base32
+ "1gk80zj711rcnk06cvszic7lpm06nj47kbypg13rpijdzfsvmi8m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/iwona")
(synopsis "Sans-serif typeface for TeX")
- (description "Iwona is a two-element sans-serif typeface. It was created
+ (description "Iwona is a two-element sans-serif typeface. It was created
as an alternative version of the Kurier typeface, which was designed in 1975
for a diploma in typeface design at the Warsaw Academy of Fine Arts under the
supervision of Roman Tomaszewski. Kurier was designed for linotype
@@ -7936,6 +7925,8 @@ alternative version of the Kurier fonts. The difference lies in the absence
of ink traps which typify the Kurier font.")
(license license:gfl1.0)))
+(define-deprecated-package texlive-fonts-iwona texlive-iwona)
+
(define-public texlive-jknappen
(package
(inherit (simple-texlive-package