aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm53
1 files changed, 22 insertions, 31 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f98945d1f4..884f35c959 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7895,39 +7895,28 @@ TeX metrics (VF and TFM files) and macros for use with LaTeX.")
(define-deprecated-package texlive-fonts-txfonts texlive-txfonts)
-(define-public texlive-fonts-iwona
+(define-public texlive-iwona
(package
- (name "texlive-fonts-iwona")
- (version "0.995b")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://jmn.pl/pliki/Iwona-tex-"
- (string-map (lambda (c)
- (if (char=? c #\.)
- #\_ c))
- version)
- ".zip"))
- (sha256
- (base32
- "13684iqx5granpc5rfvqnmyvdpgpbr1x9y7i7y7bcaq0qxv7ph1x"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/"))
- (unzip (search-input-file %build-inputs "/bin/unzip")))
- (invoke unzip (assoc-ref %build-inputs "source"))
- (mkdir-p target)
- (copy-recursively "iwona" target)
- #t))))
- (native-inputs
- (list unzip))
- (home-page "http://jmn.pl/en/kurier-i-iwona/")
+ (name "texlive-iwona")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/iwona/"
+ "fonts/afm/nowacki/iwona/"
+ "fonts/enc/dvips/iwona/"
+ "fonts/map/dvips/iwona/"
+ "fonts/opentype/nowacki/iwona/"
+ "fonts/tfm/nowacki/iwona/"
+ "fonts/type1/nowacki/iwona/"
+ "tex/latex/iwona/"
+ "tex/plain/iwona/")
+ (base32
+ "1gk80zj711rcnk06cvszic7lpm06nj47kbypg13rpijdzfsvmi8m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/iwona")
(synopsis "Sans-serif typeface for TeX")
- (description "Iwona is a two-element sans-serif typeface. It was created
+ (description "Iwona is a two-element sans-serif typeface. It was created
as an alternative version of the Kurier typeface, which was designed in 1975
for a diploma in typeface design at the Warsaw Academy of Fine Arts under the
supervision of Roman Tomaszewski. Kurier was designed for linotype
@@ -7936,6 +7925,8 @@ alternative version of the Kurier fonts. The difference lies in the absence
of ink traps which typify the Kurier font.")
(license license:gfl1.0)))
+(define-deprecated-package texlive-fonts-iwona texlive-iwona)
+
(define-public texlive-jknappen
(package
(inherit (simple-texlive-package