aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 07:57:29 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:39 +0000
commit8ac97dcea21b56ef53b8cfff5063b18b432ceb39 (patch)
treef6bf7be5c60d970242ba9f03d3817f7483604f36
parent2d4cc4251ecdbfffb2074da3c7e884e4fb4fc1c9 (diff)
downloadguix-8ac97dcea21b56ef53b8cfff5063b18b432ceb39.tar.gz
guix-8ac97dcea21b56ef53b8cfff5063b18b432ceb39.zip
gnu: python-jedi: Update to 0.19.1.
* gnu/packages/python-xyz.scm (python-jedi): Update to 0.19.1. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase; add 'set-HOME phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Iee74d0850e294cec2e139039d1f93b429e76c29d
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6d3eb9fe7..06e8597ccb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22731,7 +22731,7 @@ scans through a file and detects issues.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.18.2")
+ (version "0.19.1")
(source
(origin
(method git-fetch)
@@ -22742,19 +22742,20 @@ scans through a file and detects issues.")
(file-name (git-file-name name version))
(sha256
(base32
- "1nhsajmkn3qj32k5z3ymrd3r6dz2aliv2pqb824m5kaib986dm44"))
- (modules '((guix build utils)))))
- (build-system python-build-system)
+ "1lpvxa16zyhg95s8ji3sm19qz3bawal172xwlzcl5h80mhhfagih"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME" "/tmp")
- (invoke "python" "-m" "pytest" "-vv")))))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
(native-inputs
- (list python-colorama python-docopt python-pytest))
+ (list python-colorama
+ python-docopt
+ python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-parso))
(home-page "https://github.com/davidhalter/jedi")