aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 07:55:44 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:38 +0000
commit2d4cc4251ecdbfffb2074da3c7e884e4fb4fc1c9 (patch)
tree6ef95fe6f938e16a84fde5b9a2af449438153842
parent83852d55a2743ff5c581f50d99da7c95d1e8613b (diff)
downloadguix-2d4cc4251ecdbfffb2074da3c7e884e4fb4fc1c9.tar.gz
guix-2d4cc4251ecdbfffb2074da3c7e884e4fb4fc1c9.zip
gnu: python-attrs: Update to 23.2.0.
* gnu/packages/python-xyz.scm (python-attrs): Update to 23.2.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Remove python-coverage, python-hypothesis, and python-six; add python-hatchling, python-hatch-fancy-pypi-readme, python-hatch-vcs, python-pytest-xdist, and python-zope-interface. (python-attrs-bootstrap)[native-inputs]: Add python-hatchling, python-hatch-fancy-pypi-readme, python-hatch-vcs. Change-Id: I19f99b38589db7de0f6a78d6e0f126118dbe2b1d
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 22 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c02b09e3c0..c6d3eb9fe7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24741,29 +24741,32 @@ both as keys and as attributes.")
(define-public python-attrs
(package
(name "python-attrs")
- (version "21.2.0")
+ (version "23.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "attrs" version))
(sha256
(base32
- "1yzmwi5d197p0qhl7rl4xi9q1w8mk9i3zn6hrl22knbcrb1slspg"))))
- (build-system python-build-system)
+ "0c0zjwcqzbmpl93izm2g37gc3lsbbb9pf275fv7zcqn256sw6pck"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'remove-test-hypothesis-deadlines
- (lambda _
- (substitute* "tests/test_make.py"
- (("assume, given") "assume, given, settings")
- (("( +)@given" all spaces)
- (string-append spaces "@settings(deadline=None)\n" all)))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'remove-test-hypothesis-deadlines
+ (lambda _
+ (substitute* "tests/test_make.py"
+ (("assume, given") "assume, given, settings")
+ (("( +)@given" all spaces)
+ (string-append spaces "@settings(deadline=None)\n" all))))))))
(native-inputs
- (list python-coverage python-hypothesis python-pympler python-pytest
- python-six))
+ (list python-hatchling
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs
+ python-pympler
+ python-pytest
+ python-pytest-xdist
+ python-zope-interface))
(home-page "https://github.com/python-attrs/attrs/")
(synopsis "Attributes without boilerplate")
(description "@code{attrs} is a Python package with class decorators that
@@ -24775,7 +24778,9 @@ both as keys and as attributes.")
(package
(inherit python-attrs)
(name "python-attrs-bootstrap")
- (native-inputs `())
+ (native-inputs (list python-hatchling
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs))
(arguments `(#:tests? #f))))
(define-public python-cliapp