aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:36 +0200
commit86d697de36cc7786373423fd3587427a7364dc7e (patch)
treed08bd0fb80c0e5ac8fef13effec8bc75a0706fa0
parent05b2c22ffbb6c0d8d0fd6d873e0519dee5742a0d (diff)
downloadguix-86d697de36cc7786373423fd3587427a7364dc7e.tar.gz
guix-86d697de36cc7786373423fd3587427a7364dc7e.zip
gnu: Add texlive-regcount.
* gnu/packages/tex.scm (texlive-regcount): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 575733c9e5..966acbe00d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93832,6 +93832,28 @@ style) for writing technical reference manuals. It offers a wide left margin
for notes to the reader, like some of the manuals distributed by Adobe.")
(license license:lppl)))
+(define-public texlive-regcount
+ (package
+ (name "texlive-regcount")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/regcount/"
+ "source/latex/regcount/"
+ "tex/latex/regcount/")
+ (base32
+ "1iyc21qs4y5cf1xbqz6h7hpv5w2aplb5xlczzkva23n562gg3gf7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/regcount")
+ (synopsis "Display the allocation status of the TeX registers")
+ (description
+ "The package adds a macro @code{\\rgcounts} which displays the allocation
+status of the TeX registers. The display is written into the @file{.log} file
+as it is a bit verbose. An automatic call to @code{\\rgcounts} is done at
+@code{\\begin@{document@}} and @code{\\end@{document@}}.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar