aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 10:11:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:43 +0000
commit860c68d6c568d54e3410efc9e945d53dd78a5e28 (patch)
treeee1fd674742e0a098050b798cb2a79ef3cadf239
parent60498713fde47ba76c9f99bcd80b7b9c0948a8ae (diff)
downloadguix-860c68d6c568d54e3410efc9e945d53dd78a5e28.tar.gz
guix-860c68d6c568d54e3410efc9e945d53dd78a5e28.zip
gnu: go-github-com-google-go-cmdtest: Move to golang-build.
* gnu/packages/golang-check.scm (go-github-com-google-go-cmdtest): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: I4e6015ba18c4aa57856df32dd98199f3bcf5dc0c
-rw-r--r--gnu/packages/golang-build.scm28
-rw-r--r--gnu/packages/golang-check.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 9d9297029f..bc7e05128b 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -140,6 +140,34 @@ functions that have a name matched by regex:.")
serialization format.")
(license license:bsd-3)))
+(define-public go-github-com-google-go-cmdtest
+ (package
+ (name "go-github-com-google-go-cmdtest")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-cmdtest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkghc60ymxmg19j90r6j7clq3xifh5m9kg1bgr4zpr5sv148x72"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/google/go-cmdtest"))
+ (propagated-inputs
+ (list go-github-com-google-renameio go-github-com-google-go-cmp))
+ (home-page "https://github.com/google/go-cmdtest")
+ (synopsis "Testing for your CLI")
+ (description
+ "The cmdtest package simplifies testing of command-line interfaces. It
+provides a simple, cross-platform, shell-like language to express command
+execution. It can compare actual output with the expected output, and can
+also update a file with new \"golden\" output that is deemed correct.")
+ (license license:asl2.0)))
+
(define-public go-github-com-google-go-cmp
(package
(name "go-github-com-google-go-cmp")
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 71c8961e95..914b5ea59b 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -383,34 +383,6 @@ when comparing complex types like structures and maps.")
(description "This package provides additions to Go's stdlib testing.")
(license license:bsd-3)))
-(define-public go-github-com-google-go-cmdtest
- (package
- (name "go-github-com-google-go-cmdtest")
- (version "0.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/go-cmdtest")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0zkghc60ymxmg19j90r6j7clq3xifh5m9kg1bgr4zpr5sv148x72"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/google/go-cmdtest"))
- (propagated-inputs
- (list go-github-com-google-renameio go-github-com-google-go-cmp))
- (home-page "https://github.com/google/go-cmdtest")
- (synopsis "Testing for your CLI")
- (description
- "The cmdtest package simplifies testing of command-line interfaces. It
-provides a simple, cross-platform, shell-like language to express command
-execution. It can compare actual output with the expected output, and can
-also update a file with new \"golden\" output that is deemed correct.")
- (license license:asl2.0)))
-
(define-public go-github-com-google-gofuzz
(let ((commit "fd52762d25a41827db7ef64c43756fd4b9f7e382")
(revision "0"))