aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 9d9297029f..bc7e05128b 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -140,6 +140,34 @@ functions that have a name matched by regex:.")
serialization format.")
(license license:bsd-3)))
+(define-public go-github-com-google-go-cmdtest
+ (package
+ (name "go-github-com-google-go-cmdtest")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-cmdtest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkghc60ymxmg19j90r6j7clq3xifh5m9kg1bgr4zpr5sv148x72"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/google/go-cmdtest"))
+ (propagated-inputs
+ (list go-github-com-google-renameio go-github-com-google-go-cmp))
+ (home-page "https://github.com/google/go-cmdtest")
+ (synopsis "Testing for your CLI")
+ (description
+ "The cmdtest package simplifies testing of command-line interfaces. It
+provides a simple, cross-platform, shell-like language to express command
+execution. It can compare actual output with the expected output, and can
+also update a file with new \"golden\" output that is deemed correct.")
+ (license license:asl2.0)))
+
(define-public go-github-com-google-go-cmp
(package
(name "go-github-com-google-go-cmp")