aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 20:53:06 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:38 +0000
commit856e342fd7b0a4a58ebc407c8ed571c1bea053ec (patch)
tree3ebe822c451bae4e1d6971e962e71822aeed82a2
parent39f0bd003b25363beb8f46311afc4c3eee81e638 (diff)
downloadguix-856e342fd7b0a4a58ebc407c8ed571c1bea053ec.tar.gz
guix-856e342fd7b0a4a58ebc407c8ed571c1bea053ec.zip
gnu: go-github-com-jaytaylor-html2text: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-jaytaylor-html2text): Move from here ... * gnu/packages/golang-web.scm ... to here. Change-Id: Ie2e79aa4a7f034579433f9ea7d55bcfdea1b90d8
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 477afba2a8..f7c787481c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2443,6 +2443,33 @@ default LAN gateway.")
port mapping and discovering the external IP address of a firewall.")
(license license:asl2.0)))
+(define-public go-github-com-jaytaylor-html2text
+ (package
+ (name "go-github-com-jaytaylor-html2text")
+ (version "0.0.0-20230321000545-74c2419ad056")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaytaylor/html2text")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14r0ph8w4yxx129kfvj0qbx4cyid65md93qmwlz2cly4iwjnr7w2"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/jaytaylor/html2text"))
+ (propagated-inputs
+ (list go-golang-org-x-net
+ go-github-com-olekukonko-tablewriter
+ go-github-com-ssor-bom))
+ (home-page "https://github.com/jaytaylor/html2text")
+ (synopsis "Convert HTML emails to text")
+ (description
+ "The html2text package converts HTML emails to plain text, allowing
+text-only mail clients to display them.")
+ (license license:expat)))
+
(define-public go-github-com-jcmturner-dnsutils-v2
(package
(name "go-github-com-jcmturner-dnsutils-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 014a347771..b8e2f81ecc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8017,32 +8017,6 @@ result is a conceptually simple, but highly performant, disk-backed storage syst
email library.")
(license license:gpl3+)))
-(define-public go-github-com-jaytaylor-html2text
- (package
- (name "go-github-com-jaytaylor-html2text")
- (version "0.0.0-20230321000545-74c2419ad056")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jaytaylor/html2text")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14r0ph8w4yxx129kfvj0qbx4cyid65md93qmwlz2cly4iwjnr7w2"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/jaytaylor/html2text"))
- (propagated-inputs (list go-golang-org-x-net
- go-github-com-olekukonko-tablewriter
- go-github-com-ssor-bom))
- (home-page "https://github.com/jaytaylor/html2text")
- (synopsis "Convert HTML emails to text")
- (description
- "The html2text package converts HTML emails to plain text, allowing
-text-only mail clients to display them.")
- (license license:expat)))
-
(define-public go-github-com-riywo-loginshell
(package
(name "go-github-com-riywo-loginshell")