aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:05:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:25 +0200
commit8205ada12ef7e6568d758a89f969cc913c77b931 (patch)
treecb776330010b86e6eedf0fafe7f305bee725855e
parent2fa0ec238c2cd79aa025f2cd54616ff5315050b0 (diff)
downloadguix-8205ada12ef7e6568d758a89f969cc913c77b931.tar.gz
guix-8205ada12ef7e6568d758a89f969cc913c77b931.zip
gnu: Add texlive-mercatormap.
* gnu/packages/tex.scm (texlive-mercatormap): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a116032cc6..a9d9d9d47f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2642,6 +2642,30 @@ and maths (advance, multiply, and divide)---in short---it takes the pain out
of PiCTeX.")
(license license:lppl)))
+(define-public texlive-mercatormap
+ (package
+ (name "texlive-mercatormap")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mercatormap/"
+ "tex/latex/mercatormap/")
+ (base32
+ "11kcwzly8m8wqyppymanpvgabyjl1w33xzsy43sb5p4xv8fdaa5j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mercatormap")
+ (synopsis
+ "Spherical Mercator coordinate systems and Web Mercator tile integration")
+ (description
+ "This package extends TikZ with tools to create map graphics. The
+provided coordinate system relies on the Web Mercator projection used on the
+Web by OpenStreetMap and others. The package supports the seamless
+integration of graphics from public map tile servers by a Python script.
+Also, common map elements like markers, geodetic networks, bar scales, routes,
+orthodrome pieces, and more are part of the package.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")