aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:05:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:25 +0200
commit2fa0ec238c2cd79aa025f2cd54616ff5315050b0 (patch)
treea484ae9d72105e3890b1e70fa3174d02298e5d86
parentb696bb1cde6aa0d401d8a18268a023d37e04f6f2 (diff)
downloadguix-2fa0ec238c2cd79aa025f2cd54616ff5315050b0.tar.gz
guix-2fa0ec238c2cd79aa025f2cd54616ff5315050b0.zip
gnu: Add texlive-mathspic.
* gnu/packages/tex.scm (texlive-mathspic): New variable.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 632d89eb4c..a116032cc6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2610,6 +2610,38 @@ border. The package also provides macros that help with the management of
shape parameters, and the definition of anchor points.")
(license license:lppl1.3+)))
+(define-public texlive-mathspic
+ (package
+ (name "texlive-mathspic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mathspic/"
+ "doc/man/man1/mathspic.1"
+ "doc/man/man1/mathspic.man1.pdf"
+ "scripts/mathspic/" "tex/latex/mathspic/")
+ (base32
+ "0rlcskfvpl4niv680v8fgfpfxkrhfavmm8431ffp3vjjbqrhv7xr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:link-scripts #~(list "mathspic.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/mathspic")
+ (synopsis "Perl filter program for use with PiCTeX")
+ (description
+ "MathsPIC (Perl) is a development of the earlier MathsPIC (DOS) program,
+now implemented as a Perl script, being much more portable than the earlier
+program. MathsPIC parses a plain text input file and generates a plain text
+output-file containing commands for drawing a diagram. It produces output
+containing PiCTeX and (La)TeX commands, which may then be processed by plain
+TeX or LaTeX in the usual way. MathsPIC also outputs a comprehensive log
+file. MathsPIC facilitates creating figures using PiCTeX by providing an
+environment for manipulating named points and also allows the use of variables
+and maths (advance, multiply, and divide)---in short---it takes the pain out
+of PiCTeX.")
+ (license license:lppl)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")