aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-18 20:16:16 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:27 +0000
commit809d36e2e22bfdfab73d2859b9fbf6224e977bd3 (patch)
treeb418e520a4418b85c5a568844632c1e86fb534be
parenta8eb940e760304959da7635d7484cd8f0a8dca62 (diff)
downloadguix-809d36e2e22bfdfab73d2859b9fbf6224e977bd3.tar.gz
guix-809d36e2e22bfdfab73d2859b9fbf6224e977bd3.zip
gnu: python-pydantic: Update to 1.10.19.
* gnu/packages/python-xyz.scm (python-pydantic): Update to 1.10.19. [build-system]: Swap to pyproject-build-system. [arguments]<test-flags>: Deselect one failing test. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I58a30ef449bf689d129bf571ecf45d2b68f0925f
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7164a67e90..203fd33307 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8225,7 +8225,7 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python-pydantic
(package
(name "python-pydantic")
- (version "1.9.1")
+ (version "1.10.19")
(source
(origin
(method git-fetch)
@@ -8234,15 +8234,18 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1406kgppqa7524mxllsipj7gb8fn7pwf51l11lqik59xjhsfv94f"))))
- (build-system python-build-system)
+ (base32 "0swcpfq1y0h5dcj82idls8k5la4xh4c0vz47y7jci2qass8gjffc"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (invoke "pytest" "-vv"))))))
+ (list
+ #:test-flags
+ ;; One test fails with not equal assertion.
+ #~(list "--deselect=tests/test_validators.py::test_assert_raises_validation_error")))
(native-inputs
- (list python-pytest python-pytest-mock))
+ (list python-pytest
+ python-pytest-mock
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-typing-extensions))
(home-page "https://github.com/samuelcolvin/pydantic")