aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:31:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:59 +0200
commit7f62cf37bf71a2df88430ab7592ac2e87ae8d8c5 (patch)
treecf362e39de8289e73d24c614228d77585c6283d5
parentf006e7939a0fb875bccec13191d11d7b5c3aaf12 (diff)
downloadguix-7f62cf37bf71a2df88430ab7592ac2e87ae8d8c5.tar.gz
guix-7f62cf37bf71a2df88430ab7592ac2e87ae8d8c5.zip
gnu: Add texlive-memorygraphs.
* gnu/packages/tex.scm (texlive-memorygraphs): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 01fed01950..438899a780 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4731,6 +4731,26 @@ to languages and computational complexity usually needed for Membrane
Computing research.")
(license license:lppl1.3+)))
+(define-public texlive-memorygraphs
+ (package
+ (name "texlive-memorygraphs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/memorygraphs/"
+ "tex/latex/memorygraphs/")
+ (base32
+ "03wsql3aq6327k905fz902il1acxcz2ik4adxfkl4vm1f1g045xn")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/memorygraphs")
+ (synopsis "TikZ styles to typeset graphs of program memory")
+ (description
+ "This package defines some TikZ styles and adds anchors to existing
+styles that ease the declaration of memory graphs. It is intended for graphs
+that represent the memory of a computer program during its execution.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")