aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:31:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:58 +0200
commitf006e7939a0fb875bccec13191d11d7b5c3aaf12 (patch)
treed28e474677229dbe60befe9ca76cfa9808047f8a
parentccad0d2cef772e10fd65d8f1a65fe568f18767ad (diff)
downloadguix-f006e7939a0fb875bccec13191d11d7b5c3aaf12.tar.gz
guix-f006e7939a0fb875bccec13191d11d7b5c3aaf12.zip
gnu: Add texlive-membranecomputing.
* gnu/packages/tex.scm (texlive-membranecomputing): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1a5e494f63..01fed01950 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4710,6 +4710,27 @@ mechanics. Since most of these formulas are long and tedious to write, this
package wraps them up in short commands.")
(license license:gpl3+)))
+(define-public texlive-membranecomputing
+ (package
+ (name "texlive-membranecomputing")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/membranecomputing/"
+ "tex/latex/membranecomputing/")
+ (base32
+ "1r5k8ipf435vvffr7da8nl2j14myfp102i5qf0yy0jczziddbq6z")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/membranecomputing")
+ (synopsis "Membrane Computing notation")
+ (description
+ "This is a LaTeX package for the Membrane Computing community. It
+comprises the definition of @samp{P} systems, rules and some concepts related
+to languages and computational complexity usually needed for Membrane
+Computing research.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")