aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:37 +0200
commit7c5313a4afb523ddb159f2870ad54f3cbaa1c119 (patch)
treec411a3fcb12884a2f3bd3f1c5bf86efdc4fde57e
parent86d697de36cc7786373423fd3587427a7364dc7e (diff)
downloadguix-7c5313a4afb523ddb159f2870ad54f3cbaa1c119.tar.gz
guix-7c5313a4afb523ddb159f2870ad54f3cbaa1c119.zip
gnu: Add texlive-register.
* gnu/packages/tex.scm (texlive-register): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 966acbe00d..79e5dcb567 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93854,6 +93854,32 @@ as it is a bit verbose. An automatic call to @code{\\rgcounts} is done at
@code{\\begin@{document@}} and @code{\\end@{document@}}.")
(license license:lppl)))
+(define-public texlive-register
+ (package
+ (name "texlive-register")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/register/"
+ "source/latex/register/"
+ "tex/latex/register/")
+ (base32
+ "0zcffpp53dg59d7l24vsl6qjb6qfhmfbvwcbr658jhdmhawkzirr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/register")
+ (synopsis "Typeset programmable elements in digital hardware (registers)")
+ (description
+ "This package is designed for typesetting the programmable elements in digital
+hardware, i.e., registers. Such registers typically have many fields and can
+be quite wide; they are thus a challenge to typeset in a consistent manner.
+Register is similar in some aspects to the @code{bytefield} and
+@code{bitpattern} packages. Anyone doing hardware documentation using LaTeX
+should examine those packages. An example Perl module and script are
+provided, to convert the register specifications into structures suitable for,
+say, a pre-silicon test environment.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar