aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 00:23:47 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:42 +0000
commit76fa5c09171ca0334ffc2e11835220e8164e5daa (patch)
tree81fa0ac04b9d641c50cee3058e6d4ac67257db35
parent42fb312817ae06aa93e1d5640674acfd2f1f5c08 (diff)
downloadguix-76fa5c09171ca0334ffc2e11835220e8164e5daa.tar.gz
guix-76fa5c09171ca0334ffc2e11835220e8164e5daa.zip
gnu: python-lazy-object-proxy: Update to 1.10.0.
* gnu/packages/python-xyz.scm (python-lazy-object-proxy): Update to 1.10.0. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-pip, python-setuptools, and python-wheel. Change-Id: I00dc2fa164c8b7ca8b13ac8537c30d1fdb507b9f
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 35f671bde5..b2d4bbbd69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22460,18 +22460,21 @@ times.
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")
- (version "1.5.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "lazy-object-proxy" version))
- (sha256
- (base32
- "0hwh29m9wa582ramj30p4pysckdrmki1z1b8iaaxk6mpfx2kc8wp"))))
+ (version "1.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lazy-object-proxy" version))
+ (sha256
+ (base32 "0sdc92bbzy6slcl432j04mr131cy8n0many26ppm4fpl8mnpn93q"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-setuptools-scm))
- (build-system python-build-system)
+ (list python-pip
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/ionelmc/python-lazy-object-proxy")
- (synopsis "Lazy object proxy for python")
+ (synopsis "Lazy object proxy for Python")
(description
"Lazy object proxy is an object that wraps a callable but defers the call
until the object is actually required, and caches the result of said call.")