aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 23:35:08 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:42 +0000
commit42fb312817ae06aa93e1d5640674acfd2f1f5c08 (patch)
tree2208717a760eafce750557073802936cfc302534
parent7ab238ba60bf450e2053e703b841e17835c14537 (diff)
downloadguix-42fb312817ae06aa93e1d5640674acfd2f1f5c08.tar.gz
guix-42fb312817ae06aa93e1d5640674acfd2f1f5c08.zip
gnu: python-pydata-sphinx-theme: Disable one test.
* gnu/packages/sphinx.scm (python-pydata-sphinx-theme)[build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase; disable single test. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I5849dbeab6262c41c7d525029f9acc15b4f4ee72
-rw-r--r--gnu/packages/sphinx.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 4a4332c800..03a072bc12 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2017, 2019, 2020, 2021, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2019, 2020, 2021, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016-2019, 2022, 2023 Marius Bakke <marius@gnu.org>
@@ -1388,21 +1388,20 @@ Sphinx documentation.")
(sha256
(base32
"0ph69bnnw9w8vksc7rk45q5yknsrsgk9a19xsbxym46jrmgz67b7"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ #:test-flags
+ ;; Fails due to inscrutable differences in the generated HTML
+ '(list "-k" "not test_logo")))
(propagated-inputs
(list python-beautifulsoup4
python-docutils
python-jinja2
python-sphinx))
- (native-inputs (list python-pytest python-pytest-regressions))
+ (native-inputs
+ (list python-pytest python-pytest-regressions
+ python-setuptools python-wheel))
(home-page "https://github.com/pydata/pydata-sphinx-theme")
(synopsis "Bootstrap-based Sphinx theme")
(description