aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:42:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:23 +0200
commit6963403a1c0cf2f9d2f8f31889c9cca05fa1ea23 (patch)
treead705650b4b30156e6e398c85017f101cf8b3558
parentef2d165645d3e161e596500e3e9a7e3beede4d9b (diff)
downloadguix-6963403a1c0cf2f9d2f8f31889c9cca05fa1ea23.tar.gz
guix-6963403a1c0cf2f9d2f8f31889c9cca05fa1ea23.zip
gnu: Add texlive-lpic.
* gnu/packages/tex.scm (texlive-lpic): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e5b073fc9f..cc4f121104 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2477,6 +2477,30 @@ several options for the appearance of the liftarms, a command which connects
two liftarms and an environment to describe a construction.")
(license license:lppl1.3+)))
+(define-public texlive-lpic
+ (package
+ (name "texlive-lpic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/lpic/" "tex/latex/lpic/")
+ (base32
+ "15jzvpn3gnj5c0wachbsjazll9qlibyzxf4i2g8ad7l4yd967m3c")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lpic")
+ (synopsis "Put LaTeX material over included graphics")
+ (description
+ "The package defines a convenient interface to put any LaTeX material on
+top of included graphics. The LaTeX material may also be rotated and typeset
+on top of a white box overshadowing the graphics. The coordinates of the
+LaTeX boxes are given relative to the original, unscaled graphics; when the
+graphics is rescaled, the LaTeX annotations stay at their right places (unless
+you do something extreme). In a draft mode, the package enables you to draw
+a coordinate grid over the picture for easy adjustment of positions of the
+annotations.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")