aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:42:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:22 +0200
commitef2d165645d3e161e596500e3e9a7e3beede4d9b (patch)
tree86f1d45a7b9a6b5c8209304d15854535742e72b1
parent94f89931127fa07a2a12d01bfe4f44ff1c1c1641 (diff)
downloadguix-ef2d165645d3e161e596500e3e9a7e3beede4d9b.tar.gz
guix-ef2d165645d3e161e596500e3e9a7e3beede4d9b.zip
gnu: Add texlive-liftarm.
* gnu/packages/tex.scm (texlive-liftarm): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dfdef2f907..e5b073fc9f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2458,6 +2458,25 @@ can interact with LaTeX.mk so that the latter automatically invokes
@end itemize")
(license license:gpl3+)))
+(define-public texlive-liftarm
+ (package
+ (name "texlive-liftarm")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/liftarm/" "tex/latex/liftarm/")
+ (base32
+ "1dqi322kqlqbh4hli6nwm88nsg4dkr2fnrwi4i70gxyzxdh1mjj4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/liftarm")
+ (synopsis "Draw liftarms")
+ (description
+ "This package can be used to draw liftarms with TikZ. It provides
+several options for the appearance of the liftarms, a command which connects
+two liftarms and an environment to describe a construction.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")