aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:47:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:04 +0200
commit681513a2510cdacf4dead04f6fd69a532c57432d (patch)
treef97b6b26a57e510122685ff95c2f170b92ea4754
parent120b01a2194d905ac34e289fac3764c6a81312f8 (diff)
downloadguix-681513a2510cdacf4dead04f6fd69a532c57432d.tar.gz
guix-681513a2510cdacf4dead04f6fd69a532c57432d.zip
gnu: Add texlive-tikzposter.
* gnu/packages/tex.scm (texlive-tikzposter): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 35938f970c..5ec6e6a1bb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5201,6 +5201,27 @@ and a vast set of gadgets and extras (capable of changing the wing-positions,
body-types, and more).")
(license license:gpl3)))
+(define-public texlive-tikzposter
+ (package
+ (name "texlive-tikzposter")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzposter/"
+ "source/latex/tikzposter/"
+ "tex/latex/tikzposter/")
+ (base32
+ "0hl5p14a79575s5n5rx4yy8vxcb2qrdhx851rhms7dk2sqcfynn5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzposter")
+ (synopsis "Create scientific posters using TikZ")
+ (description
+ "This package provides a document class provides a simple way of using
+TikZ for generating posters. Several formatting options are available, and
+spacing and layout of the poster is to a large extent automated.")
+ (license license:lppl1.2+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")