aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:41 +0200
commit6442ca4720a4952085506df55a175f213e46404e (patch)
treee35cd7b26e0c729a51075c3765863d1bccbea1f0
parent905c234854bf1a3be3478d0143ac05317a681f9e (diff)
downloadguix-6442ca4720a4952085506df55a175f213e46404e.tar.gz
guix-6442ca4720a4952085506df55a175f213e46404e.zip
gnu: Add texlive-rmpage.
* gnu/packages/tex.scm (texlive-rmpage): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bbf1c6e243..d9cdbb6646 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94094,6 +94094,30 @@ coordinates). You can, if you so choose, use the facilities of the
@code{labelfig} package in place of using @code{\\extralabel}.")
(license license:lppl)))
+(define-public texlive-rmpage
+ (package
+ (name "texlive-rmpage")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rmpage/" "tex/latex/rmpage/")
+ (base32
+ "0wv0nv514a8017vgbfbsykzn92lzpp7ma5hckn6fwhpvh9y8h9r7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/rmpage")
+ (synopsis "Change page layout parameters in LaTeX")
+ (description
+ "The package lets you change page layout parameters in small steps over
+a range of values using options. It can set @code{\\textwidth} appropriately
+for the main fount, and ensure that the text fits inside the printable area of
+a printer. An rmpage-formatted document can be typeset identically without
+@code{rmpage} after a single cut and paste operation. Local configuration can
+set defaults: for all documents; and by class, by printer, and by paper size.
+The @code{geometry} package is better if you want to set page layout
+parameters to particular measurements.")
+ (license license:gpl3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar