aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 14:44:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:53 +0000
commit60f1078891843fcc46cdf1b0eeec7506375a66af (patch)
treece6e3e461f8374b338bafb899ad0417359980a57
parentd5f3e947f9042e743f69f6373161f5bcabf19fc1 (diff)
downloadguix-60f1078891843fcc46cdf1b0eeec7506375a66af.tar.gz
guix-60f1078891843fcc46cdf1b0eeec7506375a66af.zip
gnu: Add go-github-com-smarty-gunit.
* gnu/packages/golang-check.scm (go-github-com-smarty-gunit): New variable. Change-Id: Ibfc07f1aaf4085b5241e2b9549f10e61f81a4187
-rw-r--r--gnu/packages/golang-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 7102146c25..aa5f12c9e9 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1175,6 +1175,30 @@ gunit @url{github.com/smarty/gunit,@code{gunit}} for use with the
functions and even in applications.")
(license license:expat)))
+(define-public go-github-com-smarty-gunit
+ (package
+ (name "go-github-com-smarty-gunit")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smarty/gunit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13bcb1aq8yshmi5inn7np5lyqhsyy5hksridi8bxbjq35xrknskr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/smarty/gunit"))
+ (home-page "https://github.com/smarty/gunit")
+ (synopsis "Golang xUnit-style test fixture test adapter")
+ (description
+ "Package gunit provides @code{testing} package hooks and convenience
+functions for writing tests in an @code{xUnit} style.")
+ (license license:expat)))
+
(define-public go-go-etcd-io-gofail
(package
(name "go-go-etcd-io-gofail")