aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 14:39:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:53 +0000
commitd5f3e947f9042e743f69f6373161f5bcabf19fc1 (patch)
tree7c100836e9e2aacff43936c845e008024a876467
parentac856615f8d6aecf23a0dcc758a98e86a671d9e7 (diff)
downloadguix-d5f3e947f9042e743f69f6373161f5bcabf19fc1.tar.gz
guix-d5f3e947f9042e743f69f6373161f5bcabf19fc1.zip
gnu: Add go-github-com-smarty-assertions.
* gnu/packages/golang-check.scm (go-github-com-smarty-assertions): New variable. Change-Id: Ibc87eb2810bb66f3ebc5b1f5a894dfcc7942a0bb
-rw-r--r--gnu/packages/golang-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 7f9fd3499c..7102146c25 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1147,6 +1147,34 @@ makes extraction of setup/teardown behavior (as well as invoking the system
under test) much simpler.")
(license license:expat)))
+(define-public go-github-com-smarty-assertions
+ (package
+ (name "go-github-com-smarty-assertions")
+ (version "1.16.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smarty/assertions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kbl6h76mjvqkgszx81allhjzy8j331dbsb090rx134swbqs0pxc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/smarty/assertions"))
+ (home-page "https://github.com/smarty/assertions")
+ (synopsis "Fluent assertion-style functions")
+ (description
+ "Package assertions contains the implementations for all assertions which
+are referenced in goconvey's
+@url{https://github.com/smartystreets/goconvey,@code{convey}} package and
+gunit @url{github.com/smarty/gunit,@code{gunit}} for use with the
+@code{So(...)} method. They can also be used in traditional Go test
+functions and even in applications.")
+ (license license:expat)))
+
(define-public go-go-etcd-io-gofail
(package
(name "go-go-etcd-io-gofail")