aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:41:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commit46751aebc87b35eef9ccfe77ddcf85ff6cba494f (patch)
tree333e0e8310996dc937121d896107ea7efb462443
parentc98ff7dcff7456ff95e2cb8e4b678e7728e74e76 (diff)
downloadguix-46751aebc87b35eef9ccfe77ddcf85ff6cba494f.tar.gz
guix-46751aebc87b35eef9ccfe77ddcf85ff6cba494f.zip
gnu: Add go-github-com-xlab-treeprint.
* gnu/packages/golang-xyz.scm (go-github-com-xlab-treeprint): New variable. Change-Id: I5bd6543c5a34881a6a1c084bdb006c6086c312e4
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a3485cee35..7b7e83508c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -7290,6 +7290,31 @@ string. The string can be a string retorned for @code{time.Duration} or a
similar string with weeks or days too.")
(license license:bsd-3)))
+(define-public go-github-com-xlab-treeprint
+ (package
+ (name "go-github-com-xlab-treeprint")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xlab/treeprint")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00k1xj3rwqa5f6n9fks8bh1m7vzssdjwxnam9kzy0rlbc74lgkl3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xlab/treeprint"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/xlab/treeprint")
+ (synopsis "ASCII tree composing tool")
+ (description
+ "This package provides a simple ASCII tree composing tool.")
+ (license license:expat)))
+
(define-public go-github-com-yuin-gopher-lua
(package
(name "go-github-com-yuin-gopher-lua")