aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty0010@zohomail.in>2025-02-15 00:35:31 +0530
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:08:40 +0000
commit57049ff631533decf5d1778c958972b51cfb8a45 (patch)
tree8cae178c8a23ef43b557a9e4badcb3b31f5995ea
parent1a0c0de2f134ea0bbf818c0aae61a0fd4f81e221 (diff)
downloadguix-57049ff631533decf5d1778c958972b51cfb8a45.tar.gz
guix-57049ff631533decf5d1778c958972b51cfb8a45.zip
gnu: Add go-github-com-zyedidia-json5.
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-json5): New variable. Change-Id: Ia931a9c4d86b4e42e45dcc72ffec58c7c3793efe Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9a00f3de54..3b9a6fcf4a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16067,6 +16067,32 @@ word-splitting rules.
It's an alternative fork of @url{https://github.com/kballard/go-shellquote}.")
(license license:expat)))
+(define-public go-github-com-zyedidia-json5
+ (package
+ (name "go-github-com-zyedidia-json5")
+ (version "0.0.0-20200102012142-2da050b1a98d")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/json5")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sgydazf3npr788b4w17ydmlh3fd1zmpriv9b69967ww90ckh2kz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/json5"))
+ (home-page "https://github.com/zyedidia/json5")
+ (synopsis "Go JSON5 decoder package based on encoding/json")
+ (description
+ "This is a Go package that implements decoding of
+@url{https://github.com/json5/json5, JSON5}.
+
+It's an alternative fork of @url{https://github.com/titanous/json5}.")
+ (license (list license:expat license:bsd-3))))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")