aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty0010@zohomail.in>2025-02-15 00:35:30 +0530
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:08:40 +0000
commit1a0c0de2f134ea0bbf818c0aae61a0fd4f81e221 (patch)
treefa5144eb747301a1711092302262dba5bdcee0b9
parent7b0c7da670352f48f680c03d06ecda5dda849d80 (diff)
downloadguix-1a0c0de2f134ea0bbf818c0aae61a0fd4f81e221.tar.gz
guix-1a0c0de2f134ea0bbf818c0aae61a0fd4f81e221.zip
gnu: Add go-github-com-zyedidia-go-shellquote.
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-shellquote): New variable. Change-Id: I39df8c180ac392cf1c89dd612921b09046c03189 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d903874fa0..9a00f3de54 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16041,6 +16041,32 @@ Platforms supported:
"It's an alternative fork of
@url{https://github.com/mattn/go-runewidth}."))))
+(define-public go-github-com-zyedidia-go-shellquote
+ (package
+ (name "go-github-com-zyedidia-go-shellquote")
+ (version "0.0.0-20200613203517-eccd813c0655")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/go-shellquote")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxjj60kicpzc6i7vigg0i8iwnhf6jawcalq201a5wkxnkmdlw9g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/kballard/go-shellquote"))
+ (home-page "https://github.com/zyedidia/go-shellquote")
+ (synopsis "Go utilities for performing shell-like word splitting/joining")
+ (description
+ "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.
+
+It's an alternative fork of @url{https://github.com/kballard/go-shellquote}.")
+ (license license:expat)))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")