aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 20:37:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:21 +0100
commit55a5a6768ea3bb4ae498d7a52754dd100ad9fecc (patch)
tree9b9071f3a47ac1a02f797ed7689aac45045d5d9e
parent9b13e9513511487d5c74b4a3da550b5d42d70b59 (diff)
downloadguix-55a5a6768ea3bb4ae498d7a52754dd100ad9fecc.tar.gz
guix-55a5a6768ea3bb4ae498d7a52754dd100ad9fecc.zip
gnu: Add python-repoze-lru.
* gnu/packages/python-xyz.scm (python-repoze-lru): New variable. Change-Id: I79b094dd7a32c70f0177f27d207b189ab2a856e5
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca7defd70c..cf6236d58b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7406,6 +7406,25 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
Microsoft Word (.docx) documents.")
(license license:expat)))
+(define-public python-repoze-lru
+ (package
+ (name "python-repoze-lru")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "repoze.lru" version))
+ (sha256
+ (base32 "0xzz1aw2smy8hdszrq8yhnklx6w1r1mf55061kalw3iq35gafa84"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-coverage python-nose python-setuptools python-wheel))
+ (home-page "https://www.repoze.org")
+ (synopsis "Tiny LRU cache implementation and decorator")
+ (description
+ "This package provides a tiny LRU cache implementation and decorator.")
+ (license license:bsd-4)))
+
(define-public python-restructuredtext-lint
(package
(name "python-restructuredtext-lint")