aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 15:01:55 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:18:10 +0000
commit54e86bc17068ae637a63ed96eb46e160b943f577 (patch)
tree3ef69f484c282247406be3b4544ba0ef6c3006f9
parentca625c595514ff6f0264d54a2f6586b404999c76 (diff)
downloadguix-54e86bc17068ae637a63ed96eb46e160b943f577.tar.gz
guix-54e86bc17068ae637a63ed96eb46e160b943f577.zip
gnu: Add go-codeberg-org-anaseto-gruid-tcell.
* gnu/packages/golang-xyz.scm (go-codeberg-org-anaseto-gruid-tcell): New variable. Change-Id: If6408b2e4b070ccc53da62f13f9dba0a7d1ae643
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index aa3991dd96..79abd0f175 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -317,6 +317,32 @@ user needs to serve using an http server a directory containing the app.wasm
file along with an index.html file.")
(license license:isc)))
+(define-public go-codeberg-org-anaseto-gruid-tcell
+ (package
+ (name "go-codeberg-org-anaseto-gruid-tcell")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/anaseto/gruid-tcell.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zr5xlmnxva5n3c5fj5hxg1wcsw1pq4favfwwv5nclwgzbd0mjr5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "codeberg.org/anaseto/gruid-tcell"))
+ (propagated-inputs
+ (list go-codeberg-org-anaseto-gruid
+ go-github-com-gdamore-tcell-v2))
+ (home-page "https://codeberg.org/anaseto/gruid-tcell")
+ (synopsis "Gruid Driver using the tcell library")
+ (description
+ "Package tcell provides a gruid Driver for making terminal apps.")
+ (license license:isc)))
+
(define-public go-dario-cat-mergo
(package
(name "go-dario-cat-mergo")