aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 14:52:30 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:18:10 +0000
commitca625c595514ff6f0264d54a2f6586b404999c76 (patch)
tree7ef64e00225e7dae4684c7cfb5ce8813ab0bf982
parent679c74fc4a2df01cb1bb370bc2aa84b383bde7c4 (diff)
downloadguix-ca625c595514ff6f0264d54a2f6586b404999c76.tar.gz
guix-ca625c595514ff6f0264d54a2f6586b404999c76.zip
gnu: Add go-codeberg-org-anaseto-gruid-sdl.
It was proposed in #57390 on <2022-08-24>. * gnu/packages/game-development.scm: Add (gnu packages golang-build). (go-codeberg-org-anaseto-gruid-sdl): New variable. Co-authored-by: Cairn <cairn@pm.me> Change-Id: Ic7c29005e788994af67ecb89065ef32a48810ede
-rw-r--r--gnu/packages/game-development.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8c7a79f0c1..fdd4931a2c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -79,6 +79,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fonts)
@@ -300,6 +301,37 @@ conversions (for example, from PPM to Doom picture format). In addition,
DeuTex has functions such as merging wads, etc.")
(license license:gpl2+)))
+(define-public go-codeberg-org-anaseto-gruid-sdl
+ (package
+ (name "go-codeberg-org-anaseto-gruid-sdl")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/anaseto/gruid-sdl.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q2k9ysfvqb715mrpk2f3sagkjmcsinh3s6nfgi6f3axckzj2351"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:skip-build? #t ; it needs to be built on final application side only
+ #:tests? #f ; no tests provided
+ #:import-path "codeberg.org/anaseto/gruid-sdl"))
+ (native-inputs
+ (list pkg-config)) ; for go-github-com-veandco-go-sdl2
+ (propagated-inputs
+ (list go-codeberg-org-anaseto-gruid
+ go-github-com-veandco-go-sdl2
+ go-golang-org-x-image))
+ (home-page "https://codeberg.org/anaseto/gruid-sdl")
+ (synopsis "Gruid Driver using the go-sdl2 SDL2 bindings")
+ (description
+ "Package sdl provides a Driver for making native graphical apps.")
+ (license license:isc)))
+
(define-public go-github-com-veandco-go-sdl2
(package
(name "go-github-com-veandco-go-sdl2")