aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 12:35:26 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commit52ad47b9cb0c108f83ab0dd6416897a32ab8f88b (patch)
tree7a269837dedc64d00db7be648c8ced80014d4392
parentc443318dad7bb5738683bcc2efa0e00e74954b86 (diff)
downloadguix-52ad47b9cb0c108f83ab0dd6416897a32ab8f88b.tar.gz
guix-52ad47b9cb0c108f83ab0dd6416897a32ab8f88b.zip
gnu: python-pytest-doctestplus: Update to 1.2.1.
* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to 1.2.1. [arguments]<test-flags>: Enable tests requiring git. <phases>: Add 'patch-git-path phase. [native-inputs]: Add git-minimal/pinned. Change-Id: If9fbec52481cc86581058e379e2f4f82ad7f1b2c
-rw-r--r--gnu/packages/python-check.scm38
1 files changed, 24 insertions, 14 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c2bf914233..e4e5c583b6 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -791,28 +792,37 @@ files and/or directories.")
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-doctestplus" version))
(sha256
- (base32 "0cmrkgpib869kpy8h8hfkg20w16lakkmbkw8cxdywpmf5wx7dbf5"))))
+ (base32 "0ybn613rp0wqzm97hncwnpn8wx7bz91rajgnclplv8yfr2iahwi4"))))
(build-system pyproject-build-system)
(arguments
- (list #:test-flags
- #~(list "-k" (string-append
- ;; Tests requiring network access.
- "not test_remote_data_url"
- " and not test_remote_data_float_cmp"
- " and not test_remote_data_ignore_whitespace"
- " and not test_remote_data_ellipsis"
- " and not test_remote_data_requires"
- " and not test_remote_data_ignore_warnings"
- ;; Requiring git available.
- " and not test_generate_diff_basic"))))
+ (list
+ #:test-flags
+ #~(list "-k" (string-join
+ ;; Tests requiring network access.
+ (list "not test_remote_data_url"
+ "test_remote_data_float_cmp"
+ "test_remote_data_ignore_whitespace"
+ "test_remote_data_ellipsis"
+ "test_remote_data_requires"
+ "test_remote_data_ignore_warnings")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-git-path
+ (lambda _
+ (substitute* "pytest_doctestplus/plugin.py"
+ (("\"git\"")
+ (format #f "'~a/bin/git'"
+ #$(this-package-native-input "git-minimal")))))))))
(native-inputs
- (list python-numpy
+ (list git-minimal/pinned
+ python-numpy
python-pytest
python-setuptools-scm
python-wheel))