aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 11:55:45 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commitc443318dad7bb5738683bcc2efa0e00e74954b86 (patch)
tree3f586ba1717e7c8150ad4f6516466c22aabe848a
parentf35a8c24164ac3d92a45695a20b2a88645eceb04 (diff)
downloadguix-c443318dad7bb5738683bcc2efa0e00e74954b86.tar.gz
guix-c443318dad7bb5738683bcc2efa0e00e74954b86.zip
gnu: python-pytest-flake8: Update to 1.3.0.
* gnu/packages/python-check.scm (python-pytest-flake8): Update to 1.3.0. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I4fc09e232585d3c92d27609e5d2d10c9d01bc7a5
-rw-r--r--gnu/packages/python-check.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 9d555f860b..c2bf914233 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1408,19 +1408,21 @@ friendly library for concurrency and async I/O in Python.")
(define-public python-pytest-flake8
(package
(name "python-pytest-flake8")
- (version "1.0.7")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytest-flake8" version))
+ (uri (pypi-uri "pytest_flake8" version))
(sha256
(base32
- "0syx68xk5ss3hgp3nr2y122w0fgkzr5936ghsqrkymh3m5hrf9gh"))))
- (build-system python-build-system)
+ "1rhz7mxcg7x9dbabfcjai3zxikfgw7az07m4ddf92bg35ib3byw8"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-flake8))
- (native-inputs
- (list python-pytest))
(home-page "https://github.com/tholo/pytest-flake8")
(synopsis "Pytest plugin to check FLAKE8 requirements")
(description