aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 18:52:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:29 +0200
commit51a3fc45a69c58b43a791020f745705f72a51d1e (patch)
treed4ff354366ced18b6869c061fd3387deb6b5f559
parente31cfb0981778cd7aeb67fac35ada6bc0666636f (diff)
downloadguix-51a3fc45a69c58b43a791020f745705f72a51d1e.tar.gz
guix-51a3fc45a69c58b43a791020f745705f72a51d1e.zip
gnu: texlive-cabin: Refresh package definition.
* gnu/packages/tex.scm (texlive-cabin): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-IFTEX, TEXLIVE-FONTAXES, TEXLIVE-FONTSPEC, TEXLIVE-MWEIGHTS, TEXLIVE-XKEYVAL.
-rw-r--r--gnu/packages/tex.scm60
1 files changed, 34 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0d70b8f666..f231bb8a18 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11275,33 +11275,41 @@ or if it differs from the weight desired for another font family. The
(define-public texlive-cabin
(package
- (inherit (simple-texlive-package
- "texlive-cabin"
- (list "/doc/fonts/cabin/"
- "/fonts/enc/dvips/cabin/"
- "/fonts/map/dvips/cabin/"
- "/fonts/opentype/impallari/cabin/"
- "/fonts/tfm/impallari/cabin/"
- "/fonts/type1/impallari/cabin/"
- "/fonts/vf/impallari/cabin/"
- "/tex/latex/cabin/")
- (base32
- "1gqqqbj7i18fs1ss5n3axd821hzq5kbv1dl7dqxp4gba619f1rli")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/cabin")
+ (name "texlive-cabin")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/cabin/"
+ "fonts/enc/dvips/cabin/"
+ "fonts/map/dvips/cabin/"
+ "fonts/opentype/impallari/cabin/"
+ "fonts/tfm/impallari/cabin/"
+ "fonts/type1/impallari/cabin/"
+ "fonts/vf/impallari/cabin/"
+ "tex/latex/cabin/")
+ (base32
+ "1gqqqbj7i18fs1ss5n3axd821hzq5kbv1dl7dqxp4gba619f1rli")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-fontaxes
+ texlive-fontspec
+ texlive-iftex
+ texlive-mweights
+ texlive-xkeyval))
+ (home-page "https://ctan.org/pkg/cabin")
(synopsis "Humanist Sans Serif font with LaTeX support")
- (description "Cabin is a humanist sans with four weights, true
-italics and small capitals. According to its designer, Pablo
-Impallari, Cabin was inspired by the typefaces of Edward Johnston and
-Eric Gill. Cabin incorporates modern proportions, optical adjustments
-and some elements of the geometric sans. @code{cabin.sty} supports
-use of the font under LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX. It uses
-the @code{mweights} package to manage the user's view of all those
-font weights. An @code{sfdefault} option is provided to enable Cabin
-as the default text font. The @code{fontaxes} package is required for
-use with [pdf]LaTeX.")
- (license (list license:silofl1.1 ;for Cabin
- license:lppl)))) ;for support files
+ (description
+ "Cabin is a humanist sans with four weights and true italics and small
+capitals. According to the designer, Pablo Impallari, Cabin was inspired by
+Edward Johnston's and Eric Gill's typefaces, with a touch of modernism. Cabin
+incorporates modern proportions, optical adjustments, and some elements of the
+geometric sans. @file{cabin.sty} supports use of the font under LaTeX,
+pdfLaTeX, XeLaTeX and LuaLaTeX; it uses the @code{mweights}, to manage the
+user's view of all those font weights. An option is provided to enable Cabin
+as the default text font.")
+ (license (list license:silofl1.1 ;for Cabin
+ license:lppl)))) ;for support files
(define-public texlive-newtx
(package