aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 10:52:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 11:33:08 +0200
commit4fb3442f5bc03914b8f6effc54eb744b6cadc22a (patch)
treea381817687ed75f3a2d9282303143449a3d9c386
parentfde0f3e26129df0fe28696086660a572af7c6e8d (diff)
downloadguix-4fb3442f5bc03914b8f6effc54eb744b6cadc22a.tar.gz
guix-4fb3442f5bc03914b8f6effc54eb744b6cadc22a.zip
gnu: Add texlive-fc.
* gnu/packages/tex.scm (texlive-fc): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 77a6e5b715..3a8656e293 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11318,6 +11318,33 @@ a comfortable and straightforward way.
allow a somewhat natural formulation.")
(license license:lppl1.3c)))
+(define-public texlive-fc
+ (package
+ (name "texlive-fc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/fc/" "fonts/source/jknappen/fc/"
+ "fonts/tfm/jknappen/fc/" "tex/latex/fc/")
+ (base32
+ "0v0r8jcr1lv31mx613h76h13psj73g49p2a6dnd0nfbfharww3gr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; FIXME: Font metrics cannot be generated due to "bad pos"
+ ;; errors with "fcitt" fonts.
+ (delete 'generate-font-metrics))))
+ (native-inputs (list texlive-metafont texlive-sauter))
+ (home-page "https://ctan.org/pkg/fc")
+ (synopsis "Fonts for African languages")
+ (description
+ "This package includes fonts for African languages. The fonts are
+provided as Metafont source, in the familiar arrangement of lots of preamble
+files and a modest set of glyph specifications.")
+ (license license:gpl2)))
+
(define-public texlive-fenixpar
(package
(name "texlive-fenixpar")