aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:17:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commit4e9cd9f313ba7cca65ee5b0a221518ab8ea8ee7c (patch)
tree1f077cae58f914548a49b33235152b9bc6b7f9ab
parentf7219ce4eedb0b9e4b98455729bbbd91e4a58ac8 (diff)
downloadguix-4e9cd9f313ba7cca65ee5b0a221518ab8ea8ee7c.tar.gz
guix-4e9cd9f313ba7cca65ee5b0a221518ab8ea8ee7c.zip
gnu: Add go-github-com-circonus-labs-go-apiclient.
* gnu/packages/golang-web.scm (go-github-com-circonus-labs-go-apiclient): New variable. Change-Id: Ia623c1bf0a296201e36ee6fa97e69cc80cee1dee
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 10aa1185c0..d0bde98d8b 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -762,6 +762,34 @@ provides convenience wrappers for registering latency instrumented functions
with Go's builtin http server.")
(license license:bsd-3)))
+(define-public go-github-com-circonus-labs-go-apiclient
+ (package
+ (name "go-github-com-circonus-labs-go-apiclient")
+ (version "0.7.24")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/circonus-labs/go-apiclient")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ysfycnjmqkn1prlz68k2nkrkk3570q5gx0d6vdvvwfhvlisj4c7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/circonus-labs/go-apiclient"))
+ (propagated-inputs
+ (list go-github-com-hashicorp-go-retryablehttp
+ go-github-com-pkg-errors))
+ (home-page "https://github.com/circonus-labs/go-apiclient")
+ (synopsis "Circonus API Client for Golang")
+ (description
+ "Package apiclient provides methods for interacting with the Circonus
+API. See the full Circonus API Documentation at
+@url{https://login.circonus.com/resources/api} for more information.")
+ (license license:bsd-3)))
+
(define-public go-github-com-coder-websocket
(package
(name "go-github-com-coder-websocket")