aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:06:48 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitf7219ce4eedb0b9e4b98455729bbbd91e4a58ac8 (patch)
tree0d8795a36db554e4099347f1563a87e17b4ef3bd
parentb7e2da3cdad31f6cefd6221f9893656509d27f53 (diff)
downloadguix-f7219ce4eedb0b9e4b98455729bbbd91e4a58ac8.tar.gz
guix-f7219ce4eedb0b9e4b98455729bbbd91e4a58ac8.zip
gnu: Add go-github-com-circonus-labs-circonus-gometrics.
* gnu/packages/golang-web.scm (go-github-com-circonus-labs-circonus-gometrics): New variable. Change-Id: I5c03bc30e11d0b056198b8348ebf71646341f19f
-rw-r--r--gnu/packages/golang-web.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 5f9ff53793..10aa1185c0 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -722,6 +722,46 @@ and stop increasing when a certain threshold is met.")
(description "This package provides a CSS parser and inliner.")
(license license:expat)))
+(define-public go-github-com-circonus-labs-circonus-gometrics
+ (package
+ (name "go-github-com-circonus-labs-circonus-gometrics")
+ (version "2.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/circonus-labs/circonus-gometrics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s2wir711h0k2h8xsypgpzshccnx8jkwjfni7n32l7wd8yng9ngs"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Module name has been changed upstream, permament redirect:
+ ;; <https://github.com/circonus-labs/circonusllhist> ->
+ ;; <https://github.com/openhistogram/circonusllhist>.
+ (substitute* (find-files "." "\\.go$")
+ (("github.com/circonus-labs/circonusllhist")
+ "github.com/openhistogram/circonusllhist"))))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-skip" "TestNew|TestFlushMetrics|TestPromOutput")
+ #:import-path "github.com/circonus-labs/circonus-gometrics"))
+ (propagated-inputs
+ (list go-github-com-hashicorp-go-retryablehttp
+ go-github-com-openhistogram-circonusllhist
+ go-github-com-pkg-errors
+ go-github-com-tv42-httpunix))
+ (home-page "https://github.com/circonus-labs/circonus-gometrics")
+ (synopsis "Circonus metrics tracking for Golang")
+ (description
+ "This library supports named counters, gauges and histograms. It also
+provides convenience wrappers for registering latency instrumented functions
+with Go's builtin http server.")
+ (license license:bsd-3)))
+
(define-public go-github-com-coder-websocket
(package
(name "go-github-com-coder-websocket")